Hi. New to this forum and a new 3 1/2 owner

350 Sport & Touring, 500 Sport & Touring
Post Reply
Papa Lazarou
Posts: 3
Joined: 22 Mar 2017, 10:57

Hi. New to this forum and a new 3 1/2 owner

Post by Papa Lazarou » 22 Mar 2017, 11:08

Hi all. I live in Southern England and have just bought a 350 Strada (GT). Always wanted a Morini 3 1/2 and now I have one. I also own a Moto Guzzi Griso 1200SE.

I've registered on the UK Morini forum as well and intend to join the owner's club.

I have sorted out the truly awful front brake and it now stops, which it didn't when I got it. The Veglia speedometer is pretty bad too-I'll either get it refurbished or find a good second hand one..

I have one more problem with it that I would be grateful of advice on. Between 5000 and 6000 revs, the engine goes complete flat and loses power. The sound of the engine also changes. I have not removed the carburettors to check the jet sizes; the previous owner had them ultrasonically cleaned.

Could this be carburettor or ignition problem? Any advice gratefully received.

I'm afraid I can't speak Dutch, so can't search the forum of answers.

User avatar
350-v-twin
Site Admin
Posts: 1154
Joined: 25 Feb 2009, 16:06
Location: Den Haag (NL)
Contact:

Re: Hi. New to this forum and a new 3 1/2 owner

Post by 350-v-twin » 22 Mar 2017, 12:22

Hi Papa Lazarou,

Welcome to the Forum! Nice to have participants from the UK and other countries. English language is no problem so I'll try to help you to sort the problem.
When I first had my 1973 Strada (GT) it had the same problem. After some good advice it was quickly sorted.

There are 2 parts to check:

1) the ignition coil in the alternator. From the engine housing a black wire goes to the fusebox. In it are 4 coloured wires:
two yellow, one red, one green. Take off the green wire from the fusebox and measure the electrical restistance (in Ohm) agains mass (the frame). You should have a reading of anything between 160 and 300 Ohm. Between 160-180 Ohm the bike will probably start badly. According to the factory workshop manual the ideal resistance is 300 Ohm. I have measured 5 independent coils and they all measured 220 Ohm. My own bike with a 220 Ohm coil starts first kick.

2) most likely one or both transducers (the coils under the fueltank) are shot. They can be "half broken". This means the bike will start normally, will run normally, up to the critical point of 5,000 or 6,000 rpm. when the advance has to come in. Inside the transducers there is an HT coil. More windings of this coil are probably short-cut and this results in the problems you describe.

Fortunately you can get new transducers these days. On the early bikes they are black/square in combination with a red pickup. On later bikes the pickup is black and the transducers are grey.
On the website http://www.motomoriniclub.nl/tech.html you can read about the transducers and which types you can get as a replacement.
Mind you, after installing new transducers, you should use the strobe to set the timing correctly.

Finally, also make sure the blue (white?) wire from the transducers to mass/frame is allright: not broken and the connector properly to mass.

According to the German Morini community, the blue transducers are a good alternative for black transducers. On my 2nd Morini I have got grey transducers. I bought a new set from Nuovaray in Italy.
This is the blue one: http://www.motelek.net/andere/cdi/ducat ... 12-cdi.png for Vespa and Lambretta.

Hope this helps.

Papa Lazarou
Posts: 3
Joined: 22 Mar 2017, 10:57

Re: Hi. New to this forum and a new 3 1/2 owner

Post by Papa Lazarou » 22 Mar 2017, 13:18

very helpful!

User avatar
350-v-twin
Site Admin
Posts: 1154
Joined: 25 Feb 2009, 16:06
Location: Den Haag (NL)
Contact:

Re: Hi. New to this forum and a new 3 1/2 owner

Post by 350-v-twin » 25 Mar 2017, 10:30

Søren Hansen from Denmark has made 4 videos on the Morini ignition explaining everything you need to know.
Number 5 video is on the Kokusan ignition of the later models.

https://www.youtube.com/watch?v=FWyYDVuvCp8

https://www.youtube.com/watch?v=g17lZg56gK4

https://www.youtube.com/watch?v=qg0fszfq47k

https://www.youtube.com/watch?v=2A0AiaFlqKY

https://www.youtube.com/watch?v=ho64Yn_jBSw

Papa Lazarou
Posts: 3
Joined: 22 Mar 2017, 10:57

Re: Hi. New to this forum and a new 3 1/2 owner

Post by Papa Lazarou » 22 Apr 2017, 17:59

Thanks, ignition replaced.

However, it's still not a happy bike.

Does anyone know what size the Woodruff key on the crank shaft (for the flywheel slot)? Mine is very flat.

User avatar
350-v-twin
Site Admin
Posts: 1154
Joined: 25 Feb 2009, 16:06
Location: Den Haag (NL)
Contact:

Re: Hi. New to this forum and a new 3 1/2 owner

Post by 350-v-twin » 23 Apr 2017, 13:41

I know what you mean with the woodruff key ("spie" in Dutch), but I have no idea on the size.
Phone up NLM to ask.

What parts of the ignition did you replace?

Post Reply